Is js-yaml 5.3 vulnerable?

npm · 1 release from 5.3.0 to 5.3.0 · latest js-yaml is 5.5.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. js-yaml 5.3.0, the last 5.3 release, is affected by 1 known security advisory (1 medium). Upgrade to 5.4.1 or later to fix all of them.

Upgrade with:npm install js-yaml@5.4.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting js-yaml 5.3.0

  • MediumGHSA-r3ph-w7gj-g6xm29 Sept 2026

    js-yaml: maxTotalMergeKeys does not limit CPU use for empty merge sources

    Affected
    >=5.0.0 <5.4.1
    Fixed in
    5.4.1

Which of your client projects are still on js-yaml 5.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact js-yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other js-yaml versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.