Is js-yaml 4.2 vulnerable?

npm · 1 release from 4.2.0 to 4.2.0 · latest js-yaml is 5.5.0 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. js-yaml 4.2.0, the last 4.2 release, is affected by 3 known security advisories (3 high), including CVE-2026-84375, CVE-2026-59869. Upgrade to 4.3.2 or later to fix all of them.

Upgrade with:npm install js-yaml@4.3.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting js-yaml 4.2.0

  • HighCVE-2026-84375GHSA-2883-xcg3-v3hh8 Sept 2026

    js-yaml: maxTotalMergeKeys does not limit CPU use for empty merge sources

    Affected
    >=4.0.0 <4.3.2 · >=3.0.0 <3.15.2
    Fixed in
    3.15.2, 4.3.2
  • HighGHSA-5p4m-2wfm-xmqj6 Aug 2026

    JS-YAML: Quadratic CPU consumption in !!omap resolution (3.x and 4.x) — CVE-2026-59870 fix not backported

    Affected
    >=4.0.0 <4.3.1 · >=3.0.0 <3.15.1
    Fixed in
    3.15.1, 4.3.1
  • HighCVE-2026-59869GHSA-52cp-r559-cp3m20 Jul 2026

    js-yaml: YAML merge-key chains can force quadratic CPU consumption

    Affected
    >=3.0.0 <3.15.0 · >=4.0.0 <4.3.0
    Fixed in
    3.15.0, 4.3.0

Which of your client projects are still on js-yaml 4.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact js-yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other js-yaml versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.