Is json5 0.4 vulnerable?

npm · 1 release from 0.4.0 to 0.4.0 · latest json5 is 2.2.3 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. json5 0.4.0, the last 0.4 release, is affected by 1 known security advisory (1 high), including CVE-2022-46175. Upgrade to 1.0.2 or later to fix all of them.

Upgrade with:npm install json5@1.0.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting json5 0.4.0

  • HighCVE-2022-46175GHSA-9c47-m6qq-7p4h29 Dec 2022

    Prototype Pollution in JSON5 via Parse Method

    Affected
    >=2.0.0 <2.2.2 · <1.0.2
    Fixed in
    1.0.2, 2.2.2

Which of your client projects are still on json5 0.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact json5 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other json5 versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.