Is json5 2.1 vulnerable?
npm · 4 releases from 2.1.0 to 2.1.3 · latest json5 is 2.2.3 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. json5 2.1.3, the last 2.1 release, is affected by 1 known security advisory (1 high), including CVE-2022-46175. Upgrade to 2.2.2 or later to fix all of them.
Upgrade with:
npm install json5@2.2.2Advisories affecting json5 2.1.3
Prototype Pollution in JSON5 via Parse Method
- Affected
- >=2.0.0 <2.2.2 · <1.0.2
- Fixed in
- 1.0.2, 2.2.2
Which of your client projects are still on json5 2.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact json5 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other json5 versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.