Is loader-utils 0.1 vulnerable?

npm · 3 releases from 0.1.0 to 0.1.2 · latest loader-utils is 3.3.1 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. loader-utils 0.1.2, the last 0.1 release, is affected by 1 known security advisory (1 critical), including CVE-2022-37601. Upgrade to 1.4.1 or later to fix all of them.

Upgrade with:npm install loader-utils@1.4.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting loader-utils 0.1.2

  • CriticalCVE-2022-37601GHSA-76p3-8jx3-jpfq13 Oct 2022

    Prototype pollution in webpack loader-utils

    Affected
    >=2.0.0 <2.0.3 · <1.4.1
    Fixed in
    1.4.1, 2.0.3

Which of your client projects are still on loader-utils 0.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact loader-utils version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other loader-utils versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.