Is loader-utils 0.2 vulnerable?
npm · 18 releases from 0.2.0 to 0.2.17 · latest loader-utils is 3.3.1 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. loader-utils 0.2.17, the last 0.2 release, is affected by 1 known security advisory (1 critical), including CVE-2022-37601. Upgrade to 1.4.1 or later to fix all of them.
Upgrade with:
npm install loader-utils@1.4.1Advisories affecting loader-utils 0.2.17
Prototype pollution in webpack loader-utils
- Affected
- >=2.0.0 <2.0.3 · <1.4.1
- Fixed in
- 1.4.1, 2.0.3
Which of your client projects are still on loader-utils 0.2?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact loader-utils version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other loader-utils versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.