Is marked 2.0 vulnerable?
npm · 8 releases from 2.0.0 to 2.0.7 · latest marked is 18.1.3 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. marked 2.0.7, the last 2.0 release, is affected by 2 known security advisories (2 high), including CVE-2022-21681, CVE-2022-21680. Upgrade to 4.0.10 or later to fix all of them.
Upgrade with:
npm install marked@4.0.10Advisories affecting marked 2.0.7
Inefficient Regular Expression Complexity in marked
- Affected
- <4.0.10
- Fixed in
- 4.0.10
Inefficient Regular Expression Complexity in marked
- Affected
- <4.0.10
- Fixed in
- 4.0.10
Which of your client projects are still on marked 2.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact marked version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other marked versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.