Is marked 3.0 vulnerable?

npm · 9 releases from 3.0.0 to 3.0.8 · latest marked is 18.1.3 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. marked 3.0.8, the last 3.0 release, is affected by 2 known security advisories (2 high), including CVE-2022-21681, CVE-2022-21680. Upgrade to 4.0.10 or later to fix all of them.

Upgrade with:npm install marked@4.0.10

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting marked 3.0.8

  • HighCVE-2022-21681GHSA-5v2h-r2cx-5xgj14 Jan 2022

    Inefficient Regular Expression Complexity in marked

    Affected
    <4.0.10
    Fixed in
    4.0.10
  • HighCVE-2022-21680GHSA-rrrm-qjm4-v8hf14 Jan 2022

    Inefficient Regular Expression Complexity in marked

    Affected
    <4.0.10
    Fixed in
    4.0.10

Which of your client projects are still on marked 3.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact marked version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other marked versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.