Is ms 0.4 vulnerable?
npm · 1 release from 0.4.0 to 0.4.0 · latest ms is 2.1.3 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. ms 0.4.0, the last 0.4 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2015-8315, CVE-2017-20162. Upgrade to 2.0.0 or later to fix all of them.
Upgrade with:
npm install ms@2.0.0Advisories affecting ms 0.4.0
Vercel ms Inefficient Regular Expression Complexity vulnerability
- Affected
- <2.0.0
- Fixed in
- 2.0.0
Regular Expression Denial of Service in ms
- Affected
- <0.7.1
- Fixed in
- 0.7.1
Which of your client projects are still on ms 0.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ms version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other ms versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.