Is ms 0.7 vulnerable?

npm · 4 releases from 0.7.0 to 0.7.3 · latest ms is 2.1.3 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. ms 0.7.3, the last 0.7 release, is affected by 1 known security advisory (1 medium), including CVE-2017-20162. 1 more affects earlier 0.7.x releases. Upgrade to 2.0.0 or later to fix all of them.

Upgrade with:npm install ms@2.0.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ms 0.7.3

  • MediumCVE-2017-20162GHSA-w9mr-4mfr-499f5 Jan 2023

    Vercel ms Inefficient Regular Expression Complexity vulnerability

    Affected
    <2.0.0
    Fixed in
    2.0.0

Fixed within 0.7.x, affecting earlier releases

  • HighCVE-2015-8315GHSA-3fx5-fwvr-xrjg24 Oct 2017

    Regular Expression Denial of Service in ms

    Affected
    <0.7.1
    Fixed in
    0.7.1

Which of your client projects are still on ms 0.7?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ms version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ms versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.