Is multer 2.3 vulnerable?
npm · 1 release from 2.3.0 to 2.3.0 · latest multer is 2.5.0 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. multer 2.3.0, the last 2.3 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2026-113872, CVE-2026-88932. Upgrade to 2.5.0 or later to fix all of them.
npm install multer@2.5.0Advisories affecting multer 2.3.0
multer vulnerable to Denial of Service via a pending asynchronous fileFilter after request teardown
- Affected
- >=2.0.0 <2.5.0
- Fixed in
- 2.5.0
multer vulnerable to Denial of Service via orphaned disk writes on aborted uploads
- Affected
- >=2.2.0 <2.4.0
- Fixed in
- 2.4.0
Which of your client projects are still on multer 2.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact multer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other multer versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.