Is multer 2.4 vulnerable?

npm · 1 release from 2.4.0 to 2.4.0 · latest multer is 2.5.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. multer 2.4.0, the last 2.4 release, is affected by 1 known security advisory (1 high), including CVE-2026-113872. Upgrade to 2.5.0 or later to fix all of them.

Upgrade with:npm install multer@2.5.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting multer 2.4.0

  • HighCVE-2026-113872GHSA-q7qp-rjg7-q26m23 Oct 2026

    multer vulnerable to Denial of Service via a pending asynchronous fileFilter after request teardown

    Affected
    >=2.0.0 <2.5.0
    Fixed in
    2.5.0

Which of your client projects are still on multer 2.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact multer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other multer versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.