Is node-fetch 1.3 vulnerable?

npm · 4 releases from 1.3.0 to 1.3.3 · latest node-fetch is 3.3.2 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. node-fetch 1.3.3, the last 1.3 release, is affected by 1 known security advisory (1 high), including CVE-2022-0235. Upgrade to 2.6.7 or later to fix all of them.

Upgrade with:npm install node-fetch@2.6.7

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting node-fetch 1.3.3

  • HighCVE-2022-0235GHSA-r683-j2x4-v87g21 Jan 2022

    node-fetch forwards secure headers to untrusted sites

    Affected
    >=3.0.0 <3.1.1 · <2.6.7
    Fixed in
    2.6.7, 3.1.1

Which of your client projects are still on node-fetch 1.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact node-fetch version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other node-fetch versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.