Is nunjucks 2.0 vulnerable?

npm · 1 release from 2.0.0 to 2.0.0 · latest nunjucks is 3.2.4 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. nunjucks 2.0.0, the last 2.0 release, is affected by 2 known security advisories (2 medium), including CVE-2023-2142, CVE-2016-10547. Upgrade to 3.2.4 or later to fix all of them.

Upgrade with:npm install nunjucks@3.2.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting nunjucks 2.0.0

  • MediumCVE-2023-2142GHSA-x77j-w7wf-fjmw20 Apr 2023

    Nunjucks autoescape bypass leads to cross site scripting

    Affected
    <3.2.4
    Fixed in
    3.2.4
  • MediumCVE-2016-10547GHSA-f7ph-p5rv-phw26 Nov 2018

    Cross-Site Scripting in nunjucks

    Affected
    <2.4.3
    Fixed in
    2.4.3

Which of your client projects are still on nunjucks 2.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact nunjucks version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other nunjucks versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.