Is passport 0.1 vulnerable?
npm · 19 releases from 0.1.0 to 0.1.18 · latest passport is 0.7.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. passport 0.1.18, the last 0.1 release, is affected by 1 known security advisory (1 medium), including CVE-2022-25896. Upgrade to 0.6.0 or later to fix all of them.
Upgrade with:
npm install passport@0.6.0Advisories affecting passport 0.1.18
Passport vulnerable to session regeneration when a users logs in or out
- Affected
- <0.6.0
- Fixed in
- 0.6.0
Which of your client projects are still on passport 0.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact passport version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other passport versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.