Is passport 0.2 vulnerable?

npm · 3 releases from 0.2.0 to 0.2.2 · latest passport is 0.7.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. passport 0.2.2, the last 0.2 release, is affected by 1 known security advisory (1 medium), including CVE-2022-25896. Upgrade to 0.6.0 or later to fix all of them.

Upgrade with:npm install passport@0.6.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting passport 0.2.2

  • MediumCVE-2022-25896GHSA-v923-w3x8-wh692 Jul 2022

    Passport vulnerable to session regeneration when a users logs in or out

    Affected
    <0.6.0
    Fixed in
    0.6.0

Which of your client projects are still on passport 0.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact passport version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other passport versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.