Is postcss-selector-parser 1.3 vulnerable?

npm · 4 releases from 1.3.0 to 1.3.3 · latest postcss-selector-parser is 7.1.7 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. postcss-selector-parser 1.3.3, the last 1.3 release, is affected by 1 known security advisory (1 medium), including CVE-2026-104844. Upgrade to 6.1.5 or later to fix all of them.

Upgrade with:npm install postcss-selector-parser@6.1.5

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting postcss-selector-parser 1.3.3

  • MediumCVE-2026-104844GHSA-rj75-hqrm-r3gf5 Oct 2026

    PostCSS: Quadratic complexity in flat selector parsing allows CPU exhaustion

    Affected
    >=7.0.0 <7.1.6 · <6.1.5
    Fixed in
    6.1.5, 7.1.6

Which of your client projects are still on postcss-selector-parser 1.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact postcss-selector-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other postcss-selector-parser versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.