Is postcss 2.1 vulnerable?
npm · 3 releases from 2.1.0 to 2.1.2 · latest postcss is 8.5.32 · checked 1 Nov 2026
Yes: 6 known advisories
Yes. postcss 2.1.2, the last 2.1 release, is affected by 6 known security advisories (2 high, 4 medium), including CVE-2026-73646, CVE-2026-45623, CVE-2026-69153. Upgrade to 8.5.23 or later to fix all of them.
npm install postcss@8.5.23Advisories affecting postcss 2.1.2
PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset
- Affected
- <8.5.23
- Fixed in
- 8.5.23
PostCSS: Path Traversal in Previous Source Map Auto-Loading (sourceMappingURL) leads to Arbitrary .map File Disclosure
- Affected
- <8.5.18
- Fixed in
- 8.5.18
PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments
- Affected
- <8.5.12
- Fixed in
- 8.5.12
PostCSS has XSS via Unescaped </style> in its CSS Stringify Output
- Affected
- <8.5.10
- Fixed in
- 8.5.10
PostCSS line return parsing error
- Affected
- <8.4.31
- Fixed in
- 8.4.31
Regular Expression Denial of Service in postcss
- Affected
- >=8.0.0 <8.2.13 · <7.0.36
- Fixed in
- 7.0.36, 8.2.13
Which of your client projects are still on postcss 2.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact postcss version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other postcss versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.