Is sanitize-html 1.14 vulnerable?
npm · 4 releases from 1.14.0 to 1.14.3 · latest sanitize-html is 2.18.1 · checked 2 Nov 2026
Yes: 9 known advisories
Yes. sanitize-html 1.14.3, the last 1.14 release, is affected by 9 known security advisories (1 high, 8 medium), including CVE-2022-25887, CVE-2026-113661, CVE-2026-113654. Upgrade to 2.18.0 or later to fix all of them.
npm install sanitize-html@2.18.0Advisories affecting sanitize-html 1.14.3
ApostropheCMS: Incomplete CVE-2026-53606: `meta http-equiv=refresh` `content` still ships `javascript:` / `data:` URLs
- Affected
- <2.18.0
- Fixed in
- 2.18.0
ApostropheCMS sanitize-html: nonTextTags discard region ends early on an implied close, letting <noscript> content render
- Affected
- <2.18.0
- Fixed in
- 2.18.0
ApostropheCMS: Mutation-XSS / allowedTags bypass via literal `</textarea/>` solidus close
- Affected
- <2.17.6
- Fixed in
- 2.17.6
ApostropheCMS: Stored XSS via SVG SMIL URI-list scheme-policy bypass
- Affected
- >=1.9.0 <2.17.7
- Fixed in
- 2.17.7
sanitize-html is vulnerable to XSS through incomprehensive sanitization
- Affected
- <2.0.0-beta
- Fixed in
- 2.0.0-beta
sanitize-html Information Exposure vulnerability
- Affected
- <2.12.1
- Fixed in
- 2.12.1
Sanitize-html Vulnerable To REDoS Attacks
- Affected
- <2.7.1
- Fixed in
- 2.7.1
Improper Input Validation in sanitize-html
- Affected
- <2.3.2
- Fixed in
- 2.3.2
Improper Input Validation in sanitize-html
- Affected
- <2.3.1
- Fixed in
- 2.3.1
Which of your client projects are still on sanitize-html 1.14?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sanitize-html version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other sanitize-html versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.