Is sharp 0.17 vulnerable?

npm · 4 releases from 0.17.0 to 0.17.3 · latest sharp is 0.35.5 · checked 1 Nov 2026

Yes: 5 known advisories

Yes. sharp 0.17.3, the last 0.17 release, is affected by 5 known security advisories (4 high, 1 medium), including CVE-2026-114111, CVE-2026-114112, CVE-2026-114113. Upgrade to 0.35.5 or later to fix all of them.

Upgrade with:npm install sharp@0.35.5

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting sharp 0.17.3

  • HighCVE-2026-114111GHSA-wq5f-xc86-pv6w6 Oct 2026

    sharp : Vulnerability in librsvg dependency CVE-2026-96889

    Affected
    <0.35.5
    Fixed in
    0.35.5
  • HighCVE-2026-114112GHSA-rgj7-g3m4-5g8c8 Sept 2026

    sharp: Vulnerabilities in libheif: GHSA-g89c-p67h-r497 and GHSA-2jg2-4ch7-h545

    Affected
    <0.35.4
    Fixed in
    0.35.4
  • HighCVE-2026-114113GHSA-f88m-g3jw-g9cj21 Jul 2026

    sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591

    Affected
    <0.35.0
    Fixed in
    0.35.0
  • HighGHSA-54xq-cgqr-rpm316 Nov 2023

    sharp vulnerability in libwebp dependency CVE-2023-4863

    Affected
    <0.32.6
    Fixed in
    0.32.6
  • MediumCVE-2022-29256GHSA-gp95-ppv5-3jc51 Jun 2022

    sharp vulnerable to Command Injection in post-installation over build environment

    Affected
    <0.30.5
    Fixed in
    0.30.5

Which of your client projects are still on sharp 0.17?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sharp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other sharp versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.