Is socket.io-parser 1.0 vulnerable?
npm · 2 releases from 1.0.1 to 1.0.2 · latest socket.io-parser is 4.2.7 · checked 1 Nov 2026
Yes: 5 known advisories
Yes. socket.io-parser 1.0.2, the last 1.0 release, is affected by 5 known security advisories (1 critical, 3 high, 1 medium), including CVE-2022-2421, CVE-2026-69185, CVE-2026-33151. Upgrade to 3.3.6 or later to fix all of them.
npm install socket.io-parser@3.3.6Advisories affecting socket.io-parser 1.0.2
Socket.IO: Zero-attachment Memory Exhaustion
- Affected
- >=4.0.0 <4.2.7 · >=3.4.0 <3.4.5 · <3.3.6
- Fixed in
- 3.3.6, 3.4.5, 4.2.7
socket.io allows an unbounded number of binary attachments
- Affected
- <3.3.5 · >=3.4.0 <3.4.4 · >=4.0.0 <4.2.6
- Fixed in
- 3.3.5, 3.4.4, 4.2.6
Insufficient validation when decoding a Socket.IO packet
- Affected
- >=4.0.4 <4.2.3 · >=3.4.0 <3.4.3 · <3.3.4
- Fixed in
- 3.3.4, 3.4.3, 4.2.3
Insufficient validation when decoding a Socket.IO packet
- Affected
- >=4.0.0 <4.0.5 · >=4.1.0 <4.2.1 · <3.3.3 · >=3.4.0 <3.4.2
- Fixed in
- 3.3.3, 3.4.2, 4.0.5, 4.2.1
Resource exhaustion in socket.io-parser
- Affected
- <3.3.2 · >=3.4.0 <3.4.1
- Fixed in
- 3.3.2, 3.4.1
Which of your client projects are still on socket.io-parser 1.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact socket.io-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other socket.io-parser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.