Is socket.io 1.2 vulnerable?

npm · 2 releases from 1.2.0 to 1.2.1 · latest socket.io is 4.8.4 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. socket.io 1.2.1, the last 1.2 release, is affected by 2 known security advisories (2 medium), including CVE-2024-38355, CVE-2020-28481. Upgrade to 2.5.1 or later to fix all of them.

Upgrade with:npm install socket.io@2.5.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting socket.io 1.2.1

  • MediumCVE-2024-38355GHSA-25hc-qcg6-38wj19 Jun 2024

    socket.io has an unhandled 'error' event

    Affected
    <2.5.1 · >=3.0.0 <4.6.2
    Fixed in
    2.5.1, 4.6.2
  • MediumCVE-2020-28481GHSA-fxwf-4rqh-v8g320 Jan 2021

    CORS misconfiguration in socket.io

    Affected
    <2.4.0
    Fixed in
    2.4.0

Which of your client projects are still on socket.io 1.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact socket.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other socket.io versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.