Is socket.io 1.4 vulnerable?
npm · 9 releases from 1.4.0 to 1.4.8 · latest socket.io is 4.8.4 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. socket.io 1.4.8, the last 1.4 release, is affected by 2 known security advisories (2 medium), including CVE-2024-38355, CVE-2020-28481. Upgrade to 2.5.1 or later to fix all of them.
Upgrade with:
npm install socket.io@2.5.1Advisories affecting socket.io 1.4.8
socket.io has an unhandled 'error' event
- Affected
- <2.5.1 · >=3.0.0 <4.6.2
- Fixed in
- 2.5.1, 4.6.2
CORS misconfiguration in socket.io
- Affected
- <2.4.0
- Fixed in
- 2.4.0
Which of your client projects are still on socket.io 1.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact socket.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other socket.io versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.