Is ua-parser-js 0.6 vulnerable?

npm · 2 releases from 0.6.0 to 0.6.2 · latest ua-parser-js is 2.0.10 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. ua-parser-js 0.6.2, the last 0.6 release, is affected by 2 known security advisories (2 high), including CVE-2020-7793, CVE-2020-7733. Upgrade to 0.7.23 or later to fix all of them.

Upgrade with:npm install ua-parser-js@0.7.23

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ua-parser-js 0.6.2

  • HighCVE-2020-7793GHSA-394c-5j6w-4xmx9 Feb 2022

    ua-parser-js Regular Expression Denial of Service vulnerability

    Affected
    <0.7.23
    Fixed in
    0.7.23
  • HighCVE-2020-7733GHSA-662x-fhqg-9p8v7 May 2021

    Regular Expression Denial of Service in ua-parser-js

    Affected
    <0.7.22
    Fixed in
    0.7.22

Which of your client projects are still on ua-parser-js 0.6?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ua-parser-js version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ua-parser-js versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.