Is ua-parser-js 0.8 vulnerable?

npm · 1 release from 0.8.1 to 0.8.1 · latest ua-parser-js is 2.0.10 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. ua-parser-js 0.8.1, the last 0.8 release, is affected by 1 known security advisory (1 high), including CVE-2022-25927. Upgrade to 1.0.33 or later to fix all of them.

Upgrade with:npm install ua-parser-js@1.0.33

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ua-parser-js 0.8.1

  • HighCVE-2022-25927GHSA-fhg7-m89q-25r324 Jan 2023

    ReDoS Vulnerability in ua-parser-js version

    Affected
    >=0.7.30 <0.7.33 · >=0.8.0 <1.0.33
    Fixed in
    0.7.33, 1.0.33

Which of your client projects are still on ua-parser-js 0.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ua-parser-js version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ua-parser-js versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.