Is webpack 5.92 vulnerable?

npm · 2 releases from 5.92.0 to 5.92.1 · latest webpack is 5.112.2 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. webpack 5.92.1, the last 5.92 release, is affected by 3 known security advisories (1 medium, 2 low), including CVE-2024-43788, CVE-2025-68458, CVE-2025-68157. Upgrade to 5.104.1 or later to fix all of them.

Upgrade with:npm install webpack@5.104.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting webpack 5.92.1

  • LowCVE-2025-68458GHSA-8fgc-7cc6-rx7x5 Feb 2026

    webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior

    Affected
    >=5.49.0 <5.104.1
    Fixed in
    5.104.1
  • LowCVE-2025-68157GHSA-38r7-794h-57585 Feb 2026

    webpack buildHttp HttpUriPlugin allowedUris bypass via HTTP redirects → SSRF + cache persistence

    Affected
    >=5.49.0 <5.104.0
    Fixed in
    5.104.0
  • MediumCVE-2024-43788GHSA-4vvj-4cpr-p98627 Aug 2024

    Webpack's AutoPublicPathRuntimeModule has a DOM Clobbering Gadget that leads to XSS

    Affected
    >=5.0.0-alpha.0 <5.94.0
    Fixed in
    5.94.0

Which of your client projects are still on webpack 5.92?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact webpack version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other webpack versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.