Is webpack 5.94 vulnerable?
npm · 1 release from 5.94.0 to 5.94.0 · latest webpack is 5.112.2 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. webpack 5.94.0, the last 5.94 release, is affected by 2 known security advisories (2 low), including CVE-2025-68458, CVE-2025-68157. Upgrade to 5.104.1 or later to fix all of them.
npm install webpack@5.104.1Advisories affecting webpack 5.94.0
webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior
- Affected
- >=5.49.0 <5.104.1
- Fixed in
- 5.104.1
webpack buildHttp HttpUriPlugin allowedUris bypass via HTTP redirects → SSRF + cache persistence
- Affected
- >=5.49.0 <5.104.0
- Fixed in
- 5.104.0
Which of your client projects are still on webpack 5.94?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact webpack version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other webpack versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.