Is ws 6.1 vulnerable?
npm · 5 releases from 6.1.0 to 6.1.4 · latest ws is 8.22.1 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. ws 6.1.4, the last 6.1 release, is affected by 3 known security advisories (2 high, 1 medium), including CVE-2026-48779, CVE-2024-37890, CVE-2021-32640. Upgrade to 6.2.4 or later to fix all of them.
npm install ws@6.2.4Advisories affecting ws 6.1.4
ws: Memory exhaustion DoS from tiny fragments and data chunks
- Affected
- >=1.1.0 <5.2.5 · >=6.0.0 <6.2.4 · >=7.0.0 <7.5.11 · >=8.0.0 <8.21.0
- Fixed in
- 5.2.5, 6.2.4, 7.5.11, 8.21.0
ws affected by a DoS when handling a request with many HTTP headers
- Affected
- >=2.1.0 <5.2.4 · >=6.0.0 <6.2.3 · >=7.0.0 <7.5.10 · >=8.0.0 <8.17.1
- Fixed in
- 5.2.4, 6.2.3, 7.5.10, 8.17.1
ReDoS in Sec-Websocket-Protocol header
- Affected
- >=7.0.0 <7.4.6 · >=6.0.0 <6.2.2 · >=5.0.0 <5.2.3
- Fixed in
- 5.2.3, 6.2.2, 7.4.6
Which of your client projects are still on ws 6.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ws version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other ws versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.