Is cakephp/cakephp 3.3 vulnerable?
Composer · 17 releases from 3.3.0 to 3.3.16 · latest cakephp/cakephp is 5.4.4 · checked 2 Nov 2026
Yes: 4 known advisories
Yes. cakephp/cakephp 3.3.16, the last 3.3 release, is affected by 4 known security advisories (1 critical, 1 high, 2 medium), including CVE-2026-79752, CVE-2019-11458, CVE-2026-48820. Upgrade to 4.5.12 or later to fix all of them.
composer require cakephp/cakephp:^4.5.12Advisories affecting cakephp/cakephp 3.3.16
CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection
- Affected
- <4.5.12 · >=4.6.0 <4.6.5 · >=5.0.0 <5.1.9 · >=5.2.0 <5.2.14 · >=5.3.0 <5.3.7
- Fixed in
- 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
CakePHP: View::element() is missing a path containment check
- Affected
- >=5.3.0 <5.3.6 · >=5.2.0 <5.2.13 · >=5.0.0 <5.1.7 · >=4.6.0 <4.6.4 · <4.5.11
- Fixed in
- 4.5.11, 4.6.4, 5.1.7, 5.2.13, 5.3.6
Cross-Site Request Forgery in CakePHP
- Affected
- >=4.0.0 <4.0.6 · <3.10.3
- Fixed in
- 3.10.3, 4.0.6
Unsafe deserialization in SmtpTransport in CakePHP
- Affected
- >=3.0.0 <3.5.18 · >=3.6.0 <3.6.15 · >=3.7.0 <3.7.7
- Fixed in
- 3.5.18, 3.6.15, 3.7.7
Which of your client projects are still on cakephp/cakephp 3.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact cakephp/cakephp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other cakephp/cakephp versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.