Is cakephp/cakephp 5.0 vulnerable?
Composer · 12 releases from 5.0.0 to 5.0.11 · latest cakephp/cakephp is 5.4.4 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. cakephp/cakephp 5.0.11, the last 5.0 release, is affected by 3 known security advisories (1 critical, 1 high, 1 medium), including CVE-2026-79752, CVE-2026-119417, CVE-2026-48820. Upgrade to 5.1.9 or later to fix all of them.
composer require cakephp/cakephp:^5.1.9Advisories affecting cakephp/cakephp 5.0.11
CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection
- Affected
- <4.5.12 · >=4.6.0 <4.6.5 · >=5.0.0 <5.1.9 · >=5.2.0 <5.2.14 · >=5.3.0 <5.3.7
- Fixed in
- 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
CakePHP: SmtpTransport vulnerable to CRLF header injection
- Affected
- >=4.5.0 <4.5.12 · >=4.6.0 <4.6.5 · >=5.0.0 <5.1.9 · >=5.2.0 <5.2.14 · >=5.3.0 <5.3.7
- Fixed in
- 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
CakePHP: View::element() is missing a path containment check
- Affected
- >=5.3.0 <5.3.6 · >=5.2.0 <5.2.13 · >=5.0.0 <5.1.7 · >=4.6.0 <4.6.4 · <4.5.11
- Fixed in
- 4.5.11, 4.6.4, 5.1.7, 5.2.13, 5.3.6
Which of your client projects are still on cakephp/cakephp 5.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact cakephp/cakephp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other cakephp/cakephp versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.