Is cakephp/cakephp 5.1 vulnerable?
Composer · 10 releases from 5.1.0 to 5.1.10 · latest cakephp/cakephp is 5.4.4 · checked 1 Nov 2026
No known advisories in the last release
cakephp/cakephp 5.1.10, the last 5.1 release, has no known advisories. 4 advisories affect earlier 5.1.x releases, so update to 5.1.10.
composer require cakephp/cakephp:^5.1.10Fixed within 5.1.x, affecting earlier releases
CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection
- Affected
- <4.5.12 · >=4.6.0 <4.6.5 · >=5.0.0 <5.1.9 · >=5.2.0 <5.2.14 · >=5.3.0 <5.3.7
- Fixed in
- 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver
- Affected
- >=5.3.0 <5.3.7 · >=5.2.0 <5.2.15 · >=5.1.0 <5.1.10
- Fixed in
- 5.1.10, 5.2.15, 5.3.7
CakePHP: SmtpTransport vulnerable to CRLF header injection
- Affected
- >=4.5.0 <4.5.12 · >=4.6.0 <4.6.5 · >=5.0.0 <5.1.9 · >=5.2.0 <5.2.14 · >=5.3.0 <5.3.7
- Fixed in
- 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
CakePHP: View::element() is missing a path containment check
- Affected
- >=5.3.0 <5.3.6 · >=5.2.0 <5.2.13 · >=5.0.0 <5.1.7 · >=4.6.0 <4.6.4 · <4.5.11
- Fixed in
- 4.5.11, 4.6.4, 5.1.7, 5.2.13, 5.3.6
Which of your client projects are still on cakephp/cakephp 5.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact cakephp/cakephp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other cakephp/cakephp versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.