Is cakephp/cakephp 3.9 vulnerable?

Composer · 11 releases from 3.9.0 to 3.9.10 · latest cakephp/cakephp is 5.4.4 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. cakephp/cakephp 3.9.10, the last 3.9 release, is affected by 3 known security advisories (1 critical, 2 medium), including CVE-2026-79752, CVE-2026-48820, CVE-2020-15400. Upgrade to 4.5.12 or later to fix all of them.

Upgrade with:composer require cakephp/cakephp:^4.5.12

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting cakephp/cakephp 3.9.10

  • CriticalCVE-2026-79752GHSA-vjqc-q4mp-2rvf17 Sept 2026

    CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection

    Affected
    <4.5.12 · >=4.6.0 <4.6.5 · >=5.0.0 <5.1.9 · >=5.2.0 <5.2.14 · >=5.3.0 <5.3.7
    Fixed in
    4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
  • MediumCVE-2026-48820GHSA-wpvj-hjcr-h3p226 Jun 2026

    CakePHP: View::element() is missing a path containment check

    Affected
    >=5.3.0 <5.3.6 · >=5.2.0 <5.2.13 · >=5.0.0 <5.1.7 · >=4.6.0 <4.6.4 · <4.5.11
    Fixed in
    4.5.11, 4.6.4, 5.1.7, 5.2.13, 5.3.6
  • MediumCVE-2020-15400GHSA-j33j-fg2g-mcv210 Feb 2022

    Cross-Site Request Forgery in CakePHP

    Affected
    >=4.0.0 <4.0.6 · <3.10.3
    Fixed in
    3.10.3, 4.0.6

Which of your client projects are still on cakephp/cakephp 3.9?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact cakephp/cakephp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other cakephp/cakephp versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.