Is filament/filament 3.1 vulnerable?

Composer · 48 releases from 3.1.0 to 3.1.47 · latest filament/filament is 5.11.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. filament/filament 3.1.47, the last 3.1 release, is affected by 1 known security advisory (1 medium), including CVE-2026-48500. Upgrade to 3.3.52 or later to fix all of them.

Upgrade with:composer require filament/filament:^3.3.52

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting filament/filament 3.1.47

  • MediumCVE-2026-48500GHSA-44wp-g8f4-f4v523 Jun 2026

    Filament: Unauthenticated temporary file upload on auth pages

    Affected
    >=4.0.0 <4.11.5 · >=5.0.0 <5.6.5 · >=3.0.0 <3.3.52
    Fixed in
    3.3.52, 4.11.5, 5.6.5

Which of your client projects are still on filament/filament 3.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact filament/filament version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other filament/filament versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.