Is guzzlehttp/psr7 1.1 vulnerable?
Composer · 1 release from 1.1.0 to 1.1.0 · latest guzzlehttp/psr7 is 3.2.0 · checked 2 Nov 2026
Yes: 6 known advisories
Yes. guzzlehttp/psr7 1.1.0, the last 1.1 release, is affected by 6 known security advisories (6 medium), including CVE-2026-59882, CVE-2026-55766, CVE-2026-48998. Upgrade to 2.12.3 or later to fix all of them.
composer require guzzlehttp/psr7:^2.12.3Advisories affecting guzzlehttp/psr7 1.1.0
guzzlehttp/psr7: Host Confusion via Weak URI Host Validation
- Affected
- <2.12.3
- Fixed in
- 2.12.3
guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization
- Affected
- <2.12.1
- Fixed in
- 2.12.1
guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation
- Affected
- <2.10.2
- Fixed in
- 2.10.2
guzzlehttp/psr7 has CRLF Injection via URI Host Component
- Affected
- <2.10.2
- Fixed in
- 2.10.2
Improper header name validation in guzzlehttp/psr7
- Affected
- <1.9.1 · >=2.0.0 <2.4.5
- Fixed in
- 1.9.1, 2.4.5
Improper Input Validation in guzzlehttp/psr7
- Affected
- <1.8.4 · >=2.0.0 <2.1.1
- Fixed in
- 1.8.4, 2.1.1
Which of your client projects are still on guzzlehttp/psr7 1.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact guzzlehttp/psr7 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other guzzlehttp/psr7 versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.