Is lcobucci/jwt 3.4 vulnerable?

Composer · 7 releases from 3.4.0 to 3.4.6 · latest lcobucci/jwt is 5.6.1 · checked 1 Nov 2026

No known advisories in the last release

lcobucci/jwt 3.4.6, the last 3.4 release, has no known advisories. 1 advisory affects earlier 3.4.x releases, so update to 3.4.6.

Update within 3.4:composer require lcobucci/jwt:^3.4.6

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 3.4.x, affecting earlier releases

  • MediumCVE-2021-41106GHSA-7322-jrq4-x5hf29 Sept 2021

    File reference keys leads to incorrect hashes on HMAC algorithms

    Affected
    >=3.4.0 <3.4.6 · >=4.0.0 <4.0.4 · >=4.1.0 <4.1.5
    Fixed in
    3.4.6, 4.0.4, 4.1.5

Which of your client projects are still on lcobucci/jwt 3.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact lcobucci/jwt version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other lcobucci/jwt versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.