Is lcobucci/jwt 4.1 vulnerable?
Composer · 6 releases from 4.1.0 to 4.1.5 · latest lcobucci/jwt is 5.6.1 · checked 1 Nov 2026
No known advisories in the last release
lcobucci/jwt 4.1.5, the last 4.1 release, has no known advisories. 1 advisory affects earlier 4.1.x releases, so update to 4.1.5.
Update within 4.1:
composer require lcobucci/jwt:^4.1.5Fixed within 4.1.x, affecting earlier releases
File reference keys leads to incorrect hashes on HMAC algorithms
- Affected
- >=3.4.0 <3.4.6 · >=4.0.0 <4.0.4 · >=4.1.0 <4.1.5
- Fixed in
- 3.4.6, 4.0.4, 4.1.5
Which of your client projects are still on lcobucci/jwt 4.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact lcobucci/jwt version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other lcobucci/jwt versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.