Is livewire/livewire 2.2 vulnerable?
Composer · 10 releases from 2.2.0 to 2.2.9 · latest livewire/livewire is 4.4.8 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. livewire/livewire 2.2.9, the last 2.2 release, is affected by 1 known security advisory (1 high), including CVE-2024-47823. 1 more affects earlier 2.2.x releases. Upgrade to 2.12.7 or later to fix all of them.
composer require livewire/livewire:^2.12.7Advisories affecting livewire/livewire 2.2.9
Livewire Remote Code Execution on File Uploads
- Affected
- >=3.0.0-beta.1 <3.5.2 · <2.12.7
- Fixed in
- 2.12.7, 3.5.2
Fixed within 2.2.x, affecting earlier releases
Data Leakage Vulnerability in livewire/livewire
- Affected
- >=2.2.5 <2.2.6
- Fixed in
- 2.2.6
Which of your client projects are still on livewire/livewire 2.2?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other livewire/livewire versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.