Is livewire/livewire 3.8 vulnerable?
Composer · 12 releases from 3.8.0 to 3.8.11 · latest livewire/livewire is 4.4.8 · checked 1 Nov 2026
No known advisories in the last release
livewire/livewire 3.8.11, the last 3.8 release, has no known advisories. 1 advisory affects earlier 3.8.x releases, so update to 3.8.11.
Update within 3.8:
composer require livewire/livewire:^3.8.11Fixed within 3.8.x, affecting earlier releases
Livewire DOM-based cross-site scripting during client-side state handling
- Affected
- >=3.0.0-beta.1 <3.8.3 · >=4.0.0-beta.1 <4.3.4
- Fixed in
- 3.8.3, 4.3.4
Which of your client projects are still on livewire/livewire 3.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other livewire/livewire versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.