Is livewire/livewire 4.3 vulnerable?
Composer · 6 releases from 4.3.0 to 4.3.5 · latest livewire/livewire is 4.4.8 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. livewire/livewire 4.3.5, the last 4.3 release, is affected by 1 known security advisory (1 medium). 1 more affects earlier 4.3.x releases. Upgrade to 4.4.8 or later to fix all of them.
composer require livewire/livewire:^4.4.8Advisories affecting livewire/livewire 4.3.5
Livewire: Authorization bypass in #[Authorize] via reordered parameter keys and #[Json] execution order
- Affected
- >=4.3.0 <4.4.8
- Fixed in
- 4.4.8
Fixed within 4.3.x, affecting earlier releases
Livewire DOM-based cross-site scripting during client-side state handling
- Affected
- >=3.0.0-beta.1 <3.8.3 · >=4.0.0-beta.1 <4.3.4
- Fixed in
- 3.8.3, 4.3.4
Which of your client projects are still on livewire/livewire 4.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other livewire/livewire versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.