Is livewire/livewire 2.7 vulnerable?
Composer · 3 releases from 2.7.0 to 2.7.2 · latest livewire/livewire is 4.4.8 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. livewire/livewire 2.7.2, the last 2.7 release, is affected by 1 known security advisory (1 high), including CVE-2024-47823. Upgrade to 2.12.7 or later to fix all of them.
Upgrade with:
composer require livewire/livewire:^2.12.7Advisories affecting livewire/livewire 2.7.2
Livewire Remote Code Execution on File Uploads
- Affected
- >=3.0.0-beta.1 <3.5.2 · <2.12.7
- Fixed in
- 2.12.7, 3.5.2
Which of your client projects are still on livewire/livewire 2.7?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other livewire/livewire versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.