Is phpmailer/phpmailer 6.0 vulnerable?
Composer · 8 releases from 6.0.0 to 6.0.7 · latest phpmailer/phpmailer is 7.1.1 · checked 2 Nov 2026
Yes: 3 known advisories
Yes. phpmailer/phpmailer 6.0.7, the last 6.0 release, is affected by 3 known security advisories (3 high), including CVE-2021-3603, CVE-2021-34551, CVE-2020-13625. 1 more affects earlier 6.0.x releases. Upgrade to 6.5.0 or later to fix all of them.
composer require phpmailer/phpmailer:^6.5.0Advisories affecting phpmailer/phpmailer 6.0.7
PHPMailer untrusted code may be run from an overridden address validator
- Affected
- <6.5.0
- Fixed in
- 6.5.0
Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows
- Affected
- <6.5.0
- Fixed in
- 6.5.0
Insufficient output escaping of attachment names in PHPMailer
- Affected
- <6.1.6
- Fixed in
- 6.1.6
Fixed within 6.0.x, affecting earlier releases
Phar object injection in PHPMailer
- Affected
- >=5.0.0 <5.2.27 · >=6.0.0 <6.0.6
- Fixed in
- 5.2.27, 6.0.6
Which of your client projects are still on phpmailer/phpmailer 6.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpmailer/phpmailer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other phpmailer/phpmailer versions
- phpmailer/phpmailer 6.3
- phpmailer/phpmailer 6.2
- phpmailer/phpmailer 6.1
- phpmailer/phpmailer 5.2
- phpmailer/phpmailer 7.1
- phpmailer/phpmailer 7.0
- phpmailer/phpmailer 6.12
- phpmailer/phpmailer 6.11
- phpmailer/phpmailer 6.10
- phpmailer/phpmailer 6.9
- phpmailer/phpmailer 6.8
- phpmailer/phpmailer 6.7
- All phpmailer/phpmailer advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.