Is phpmailer/phpmailer 6.1 vulnerable?
Composer · 9 releases from 6.1.0 to 6.1.8 · latest phpmailer/phpmailer is 7.1.1 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. phpmailer/phpmailer 6.1.8, the last 6.1 release, is affected by 3 known security advisories (1 critical, 2 high), including CVE-2020-36326, CVE-2021-3603, CVE-2021-34551. 1 more affects earlier 6.1.x releases. Upgrade to 6.5.0 or later to fix all of them.
composer require phpmailer/phpmailer:^6.5.0Advisories affecting phpmailer/phpmailer 6.1.8
PHPMailer untrusted code may be run from an overridden address validator
- Affected
- <6.5.0
- Fixed in
- 6.5.0
Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows
- Affected
- <6.5.0
- Fixed in
- 6.5.0
Object injection in PHPMailer/PHPMailer
- Affected
- >=6.1.8 <6.4.1
- Fixed in
- 6.4.1
Fixed within 6.1.x, affecting earlier releases
Insufficient output escaping of attachment names in PHPMailer
- Affected
- <6.1.6
- Fixed in
- 6.1.6
Which of your client projects are still on phpmailer/phpmailer 6.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpmailer/phpmailer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other phpmailer/phpmailer versions
- phpmailer/phpmailer 6.4
- phpmailer/phpmailer 6.3
- phpmailer/phpmailer 6.2
- phpmailer/phpmailer 6.0
- phpmailer/phpmailer 5.2
- phpmailer/phpmailer 7.1
- phpmailer/phpmailer 7.0
- phpmailer/phpmailer 6.12
- phpmailer/phpmailer 6.11
- phpmailer/phpmailer 6.10
- phpmailer/phpmailer 6.9
- phpmailer/phpmailer 6.8
- All phpmailer/phpmailer advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.