Is phpunit/phpunit 12.3 vulnerable?
Composer · 16 releases from 12.3.0 to 12.3.15 · latest phpunit/phpunit is 13.4.6 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. phpunit/phpunit 12.3.15, the last 12.3 release, is affected by 1 known security advisory (1 high), including CVE-2026-24765. Upgrade to 12.5.8 or later to fix all of them.
Upgrade with:
composer require phpunit/phpunit:^12.5.8Advisories affecting phpunit/phpunit 12.3.15
PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling
- Affected
- <8.5.52 · >=9.0.0 <9.6.33 · >=10.0.0 <10.5.62 · >=11.0.0 <11.5.50 · >=12.0.0 <12.5.8
- Fixed in
- 8.5.52, 9.6.33, 10.5.62, 11.5.50, 12.5.8
Which of your client projects are still on phpunit/phpunit 12.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpunit/phpunit version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other phpunit/phpunit versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.