Is slim/slim 1.6 vulnerable?

Composer · 8 releases from 1.6.0 to 1.6.7 · latest slim/slim is 4.15.3 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. slim/slim 1.6.7, the last 1.6 release, is affected by 1 known security advisory (1 high), including CVE-2015-2171. Upgrade to 2.6.0 or later to fix all of them.

Upgrade with:composer require slim/slim:^2.6.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting slim/slim 1.6.7

  • HighCVE-2015-2171GHSA-74mf-vjpg-9xh717 May 2022

    Slim vulnerable to PHP object injection

    Affected
    <2.6.0
    Fixed in
    2.6.0

Which of your client projects are still on slim/slim 1.6?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact slim/slim version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other slim/slim versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.