Is slim/slim 2.5 vulnerable?
Composer · 1 release from 2.5.0 to 2.5.0 · latest slim/slim is 4.15.3 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. slim/slim 2.5.0, the last 2.5 release, is affected by 1 known security advisory (1 high), including CVE-2015-2171. Upgrade to 2.6.0 or later to fix all of them.
Upgrade with:
composer require slim/slim:^2.6.0Advisories affecting slim/slim 2.5.0
Slim vulnerable to PHP object injection
- Affected
- <2.6.0
- Fixed in
- 2.6.0
Which of your client projects are still on slim/slim 2.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact slim/slim version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other slim/slim versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.