Is smarty/smarty 5.4 vulnerable?

Composer · 6 releases from 5.4.0 to 5.4.5 · latest smarty/smarty is 5.8.5 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. smarty/smarty 5.4.5, the last 5.4 release, is affected by 3 known security advisories (3 medium), including CVE-2026-62993, CVE-2026-62996, CVE-2026-62992. Upgrade to 5.8.4 or later to fix all of them.

Upgrade with:composer require smarty/smarty:^5.8.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting smarty/smarty 5.4.5

  • MediumCVE-2026-62993GHSA-cq55-c7wv-pxmq1 Sept 2026

    Smarty: SSRF via redirect bypass of trusted_uri using {fetch}

    Affected
    >=5.0.0 <5.8.2 · <4.5.7
    Fixed in
    4.5.7, 5.8.2
  • MediumCVE-2026-62996GHSA-rjhh-76wf-8xmw7 Aug 2026

    Smarty Security stream restriction bypass through stream: resource

    Affected
    >=5.0.0 <5.8.4
    Fixed in
    5.8.4
  • MediumCVE-2026-62992GHSA-f6wf-28g6-769x7 Aug 2026

    Smarty: Symlink path traversal out of trusted directories

    Affected
    >=5.0.0 <5.8.2 · <4.5.7
    Fixed in
    4.5.7, 5.8.2

Which of your client projects are still on smarty/smarty 5.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact smarty/smarty version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other smarty/smarty versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.