Is smarty/smarty 4.5 vulnerable?
Composer · 9 releases from 4.5.0 to 4.5.8 · latest smarty/smarty is 5.8.5 · checked 2 Nov 2026
No known advisories in the last release
smarty/smarty 4.5.8, the last 4.5 release, has no known advisories. 3 advisories affect earlier 4.5.x releases, so update to 4.5.8.
composer require smarty/smarty:^4.5.8Fixed within 4.5.x, affecting earlier releases
Smarty: SSRF via redirect bypass of trusted_uri using {fetch}
- Affected
- >=5.0.0 <5.8.2 · <4.5.7
- Fixed in
- 4.5.7, 5.8.2
Smarty: Symlink path traversal out of trusted directories
- Affected
- >=5.0.0 <5.8.2 · <4.5.7
- Fixed in
- 4.5.7, 5.8.2
Smarty vulnerable to PHP Code Injection by malicious attribute in extends-tag
- Affected
- >=5.0.0 <5.1.1 · >=3.0.0 <4.5.3
- Fixed in
- 4.5.3, 5.1.1
Which of your client projects are still on smarty/smarty 4.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact smarty/smarty version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other smarty/smarty versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.