Is smarty/smarty 4.3 vulnerable?
Composer · 6 releases from 4.3.0 to 4.3.5 · latest smarty/smarty is 5.8.5 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. smarty/smarty 4.3.5, the last 4.3 release, is affected by 3 known security advisories (1 high, 2 medium), including CVE-2024-35226, CVE-2026-62993, CVE-2026-62992. 1 more affects earlier 4.3.x releases. Upgrade to 4.5.7 or later to fix all of them.
composer require smarty/smarty:^4.5.7Advisories affecting smarty/smarty 4.3.5
Smarty: SSRF via redirect bypass of trusted_uri using {fetch}
- Affected
- >=5.0.0 <5.8.2 · <4.5.7
- Fixed in
- 4.5.7, 5.8.2
Smarty: Symlink path traversal out of trusted directories
- Affected
- >=5.0.0 <5.8.2 · <4.5.7
- Fixed in
- 4.5.7, 5.8.2
Smarty vulnerable to PHP Code Injection by malicious attribute in extends-tag
- Affected
- >=5.0.0 <5.1.1 · >=3.0.0 <4.5.3
- Fixed in
- 4.5.3, 5.1.1
Fixed within 4.3.x, affecting earlier releases
smarty Cross-site Scripting vulnerability in Javascript escaping
- Affected
- >=4.0.0 <4.3.1 · <3.1.48
- Fixed in
- 3.1.48, 4.3.1
Which of your client projects are still on smarty/smarty 4.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact smarty/smarty version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other smarty/smarty versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.