Is symfony/http-kernel 2.1 vulnerable?

Composer · 14 releases from 2.1.0 to 2.1.13 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. symfony/http-kernel 2.1.13, the last 2.1 release, is affected by 3 known security advisories (1 high, 2 medium), including CVE-2014-5245, CVE-2022-24894, CVE-2015-2308. Upgrade to 4.4.50 or later to fix all of them.

Upgrade with:composer require symfony/http-kernel:^4.4.50

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/http-kernel 2.1.13

  • HighCVE-2014-5245GHSA-wvjv-p5rr-mmqm30 May 2024

    Symfony allows direct access of ESI URLs behind a trusted proxy

    Affected
    >=2.0.0 <2.3.19 · >=2.4.0 <2.4.9 · >=2.5.0 <2.5.4
    Fixed in
    2.3.19, 2.4.9, 2.5.4
  • MediumCVE-2022-24894GHSA-h7vf-5wrv-9fhv1 Feb 2023

    Symfony storing cookie headers in HttpCache

    Affected
    >=2.0.0 <4.4.50 · >=5.0.0 <5.4.20 · >=6.0.0 <6.0.20 · >=6.1.0 <6.1.12 · >=6.2.0 <6.2.6
    Fixed in
    4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
  • MediumCVE-2015-2308GHSA-5c58-w9xc-qcj917 May 2022

    Symfony Vulnerable to PHP Eval Injection

    Affected
    >=2.0.0 <2.3.27 · >=2.4.0 <2.5.11 · >=2.6.0 <2.6.6
    Fixed in
    2.3.27, 2.5.11, 2.6.6

Which of your client projects are still on symfony/http-kernel 2.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/http-kernel versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.