Is symfony/http-kernel 2.8 vulnerable?
Composer · 53 releases from 2.8.0 to 2.8.52 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. symfony/http-kernel 2.8.52, the last 2.8 release, is affected by 1 known security advisory (1 medium), including CVE-2022-24894. 1 more affects earlier 2.8.x releases. Upgrade to 4.4.50 or later to fix all of them.
composer require symfony/http-kernel:^4.4.50Advisories affecting symfony/http-kernel 2.8.52
Symfony storing cookie headers in HttpCache
- Affected
- >=2.0.0 <4.4.50 · >=5.0.0 <5.4.20 · >=6.0.0 <6.0.20 · >=6.1.0 <6.1.12 · >=6.2.0 <6.2.6
- Fixed in
- 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
Fixed within 2.8.x, affecting earlier releases
Symfony Http-Kernel has non-constant time comparison in UriSigner
- Affected
- >=2.2.0 <2.8.52 · >=3.0.0 <3.4.35 · >=4.0.0 <4.2.12 · >=4.3.0 <4.3.8
- Fixed in
- 2.8.52, 3.4.35, 4.2.12, 4.3.8
Which of your client projects are still on symfony/http-kernel 2.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/http-kernel versions
- symfony/http-kernel 3.2
- symfony/http-kernel 3.1
- symfony/http-kernel 3.0
- symfony/http-kernel 2.7
- symfony/http-kernel 2.6
- symfony/http-kernel 2.5
- symfony/http-kernel 8.1
- symfony/http-kernel 8.0
- symfony/http-kernel 7.4
- symfony/http-kernel 7.3
- symfony/http-kernel 7.2
- symfony/http-kernel 7.1
- All symfony/http-kernel advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.